集成环信即时通讯最新版本3.6以上,提示需要java8 编译报错


compileOptions { sourceCompatibility 1.8 targetCompatibility 1.8 }

jackOptions { enabled true }
均已添加 在gradle版本不改变的情况下 该怎么处理
 
Error:Lambda coming from jar file need their interfaces on the classpath to be compiled, unknown int
共4个回复

carlwang

2020-07-22 18:13

compileOptions {    sourceCompatibility JavaVersion.VERSION_1_8    targetCompatibility JavaVersion.VERSION_1_8  } 清理一下as缓存 在app build.gradle下添加java 8支持 或者在设置中添加 如图

tianmei123

2020-07-23 10:17

清理一下as缓存 在app build.gradle下添加java 8支持 或者在设置中添加

小森威武

2020-07-23 18:34

额 谢谢你的回答  并不是很有效果,最后还是把gradle改高了 目前报了一个无法下载Error:Could not HEAD 'http://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.71/kotlin-gradle-plugin-1.2.71.pom'. Received status code 403 from server: Forbidden <a href="toggle.offline.mode">Enable Gradle 'offline mode' and sync project</a> 配置都是仿照环信demo,想问一下这个您了解么

carlwang

2020-07-27 14:54

可以翻墙试试看 顺便检查一下自己as的版本和里面加的kotlin插件版本与自己依赖的版本是否匹配
点击此处继续提问与开发者们互动

申请试用

提交后工作人员会尽快与您联系进行功能演示
技术咨询已转移到管理后台,请先登录

即时通讯云使用者请在应用详情页面咨询
客服云使用者请进入管理员模式咨询

×

在线咨询

电话咨询

技术咨询

免费试用