我把环信 EaseUIDemo集成到了自己的项目,但是经常性发生崩溃

抛出的异常
Could not find class 'android.support.v4.app.af$d', referenced from method com.easemob.chat.EMNotifier.sendNotification
我这是 debug 测试包,查看了是环信 jar 包的错误,请问你们是把 v4包也混淆了导致的这个问题吧
共2个回复

zhangnan

2015-10-16 10:36

http://stackoverflow.com/questions/21887816/could-not-find-class-android-app-notificationbuilder

Litchi

2015-10-16 11:05

我用的是 Android Studio,并且我在自己的项目中添加NotificationCompat;import android.support.v4.app.NotificationCompat;导包正常,上边的类找不到异常不应该是 v4包的原因吧,从提示看是你们 jar 包代码混淆把 v4包混淆掉了

漫步云端

2015-10-16 15:36

大家好,最近有很多外单项目APP【IM+电商+智能家居】,想组建一个兼职团队,职位为兼职项目经理,兼职安卓开发,兼职苹果开发,兼职java后台开发。我是一个程序员,主要负责java后台, 安卓等核心技术的研究实现工作。现在我们就2人,正在探索组建兼职团队,虽然一个项目就几万,但是如果团队够强大,还是有得赚的。 任务分配方面:不会将项目整包给一个人,只分配一个小模块,采用开源中国Team,Git,做完后,继续分配下一个模块,随时都可以接,随时都可以退出 酬劳方面,根据一个项目整体金额,一个人在这个项目花费时间和贡献的价值计算,可能一个项目每个人最多分配几千元,但是每个人都在成长。 QQ群498017337,如果没诚意的,请不要进入。 愿景:建立一个随时都可以走,随时都可以进来;谁都可以代替谁,谁都可以带走团队;谁都可以自由提问自由行动的,以分享为主的团队。
点击此处继续提问与开发者们互动

申请试用

提交后工作人员会尽快与您联系进行功能演示
技术咨询已转移到管理后台,请先登录

即时通讯云使用者请在应用详情页面咨询
客服云使用者请进入管理员模式咨询

×

在线咨询

电话咨询

技术咨询

免费试用