官方Demo报错

使用官方Demo时导入项目后报错
Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
问题是全局搜索compile 没有发现问题
 
共8个回复

lizg

2019-11-25 17:43

这个multidex库build的时候出问题导致的  根目录Build.gradle有加google的仓库吗?

㷣㷣

2019-11-26 10:42

嗯嗯 有google仓库 是要删除掉吗?

㷣㷣

2019-11-26 10:42

嗯嗯 有google仓库  是要删除掉吗?

lizg

2019-11-26 18:18

不是要移除 MultiDex 这个库是Google仓库下的  你的项目有使用androidX吗? application 里面加 MultiDex.install(this);

㷣㷣

2019-11-26 18:26

这个是官方Demo里的内容 已经在application里加了MultiDex.install(this); 项目名是ChatDemoUI3.0

㷣㷣

2019-11-27 18:15

这个不是我的项目 是从环信官网下载下来的ChatDemoUI3.0    application里已经有MultiDex.install(this); 

㷣㷣

2019-11-27 18:15

这个是环信官方Demo里的  项目是ChatDemoUI3.0   application里已经有MultiDex.install(this);

㷣㷣

2019-11-27 18:15

这个是官方Demo里的内容 已经在application里加了MultiDex.install(this); 项目名是ChatDemoUI3.0

㷣㷣

2019-11-27 18:15

这个是官方Demo里的内容 已经在application里加了MultiDex.install(this); 项目名是ChatDemoUI3.0

lizg

2019-12-05 10:27

您好,如果问题没有解决,可以登录IMconsole后台新建应用之后点击应用,右下角技术支持--提交工单 登录地址:https://console.easemob.com/user/login
点击此处继续提问与开发者们互动

申请试用

提交后工作人员会尽快与您联系进行功能演示
技术咨询已转移到管理后台,请先登录

即时通讯云使用者请在应用详情页面咨询
客服云使用者请进入管理员模式咨询

×

400电话

在线咨询

技术咨询

免费试用