vue采用类似官方demo的方式集成,登陆后报错stropheConn.setJid is not a function

vue采用类似官方demo的方式集成,登陆后报错stropheConn.setJid is not a function
共3个回复

梁客

2018-01-10 20:26

同样问题,怎么解决的?

梁客

2018-01-11 00:28

解决了 修改了strophe.js的引用方式 说实话 我也不知道怎么解决的…… 之前是在 index.html 中引入了 [quote] <script src="https://cdn.bootcss.com/strophe.js/1.2.8/strophe.js"></script> [/quote] 改为在入口处 [quote] import '../../utils/strophe-1.2.8';  [/quote] 另外 将 easemob-websdk 版本锁定在1.4.12,v1.5出现了莫名其妙的问题,干脆就锁定到demo使用的版本了(demo使用的是1.4.13?但是npm中v1.5以下的最高只到1.4.12)  

相当可以

2019-05-29 15:02

storphe 文件的问题,替换一下就好。 我是集成的1.11.1版本的时候遇到的这个问题,官方写的要引入 strophe-1.2.8.min.js 实际上这个文件是有问题的,我把 strophe-1.2.8.min.js 替换成 strophe-1.2.8.js 就可以了
点击此处继续提问与开发者们互动

申请试用

提交后工作人员会尽快与您联系进行功能演示
技术咨询已转移到管理后台,请先登录

即时通讯云使用者请在应用详情页面咨询
客服云使用者请进入管理员模式咨询

×

400电话

在线咨询

技术咨询

免费试用